Supported Versions

Name Supported Versions
Android 4.2.2 - 12.0 beta
iOS 9.0 - 14.7 beta, 15 beta 
Xcode 10.0 - 12.5, 13 beta
macOS Big Sur
Appium Through 1.17.1
Chrome 51 - 89
JDK Oracle JDK 1.8
SDK MinJavaVersion: '1.8.x', MinAdbVersion: '1.0.41'

Minimum Xcode versions required for typical iOS

iOS Xcode
15 beta 13 beta
14.7 12.5.1
14.6 12.5
14.5  12.5
14.4 12.4
14.3 12.3
14.2 12.2
14 12
13.7 11.7
13.6 11.6
13.5 11.5
13.4 11.4
13.3.1 11.3
13.3 11.3
13.2 11.2
13.1 11
13 11
12.4 10.3
12.3 10.2.1
12.2 10.2
12.1.3 10.1
12.1.1 10.1
12.1 10.1
12 10

*Due to an issue from Apple, XCode 11.7 doesn't support iOS 13.6 & 13.6.1, Kobiton has a work-around to solve:

  1. Quit XCode, download iOS 13.6 support files from this link: https://kobiton.s3.amazonaws.com/iOS_13.6_Support_File_for_XCode_11.7/13.6.zip
  2. Unzip and Paste it in this location: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/
  3. Re-open XCode

Otherwise, please host iOS 13.6 & 13.6.1 on a dedicated machine with Xcode 11.6.

Tip: you can host the iOS 13.6 & 13.6.1 with other iOS versions by using Xcode 12.0, it fixed the (*) issue.

Was this article helpful?
0 out of 0 found this helpful